Figma does not open in the browser

Hello! I can’t open Figma in any browser, a message appears
“Update or switch browsers
Download or upgrade to one of the following browsers to continue using Figma”.

The latest version of the browser is installed (Chrome, Safari, Firefox).
iMac 2012, 10.15.7

Hi Olga, sorry to hear you are having trouble to open Figma!
Hmm this is odd, if you have already updated to the latest version of the browser, this should work. (More information on Figma browser requirements here: https://help.figma.com/hc/en-us/articles/360039827194-Figma-browser-requirements)
Can you tell me if this happens specifically on Desktop App, Browser, or both?

I suggest you to reach out directly our support team so they can have a deeper look into what’s causing this here: https://help.figma.com/hc/en-us/requests/new Thank you!

Having the exact same issue. It sends me in a circle. I launch the desktop app and it says to sign into the Browser. I click that and it tells me that I need to install a newer version of Chrome (88+) however I’m already running the latest version (124). The only other option is to Sign into Desktop… which I click and then the circle continues.

Hey Rob!
To cover some basic troubleshooting, would you be able to check a few things for us?

  • Can you check if you are facing the same error in another browser? Our supported browsers are Chrome, Firefox, Safari and Edge.
  • Would you try clearing the Chrome browser cache?
  • As a reminder, you can see additional information on how to setup browsers for Figma in this article with the requirements here: Configure your browser for Figma

If after clearing the Chrome cache, this doesn’t help, please reach out directly to the support team so they can investigate further your issue: here
Be sure to use your Figma email account, please mention your desk/browser spec and if you are able to, a short video (screen recording). Please include the whole window and record all your steps (accessing Figma to getting the error message so we can check any relevant settings). We use these videos to try and reproduce the issue on our end. Thank you!

Hi Céline,

Thanks for the quick response. I was able to solve the issue by clearing the caches and cookies in both browsers. Cheers.

2 Likes

Glad to hear it works! Thanks for confirming.
I’ve gone and closed the thread. :slight_smile: