Figma / Difficulté pour faire les groupe auto lay out à chaque fois

Bonjour,

Je ne comprends pas pourquoi il m’est impossible d’arriver à faire des auto layouts corrects de façon automatique.

Ex: Je fais un rectangle et je mets du texte dedans par ex: “s’inscrire”. Je sélectionne le rectangle et le texte et je fais shift A pour créer un layout.

Normalement le rectangle “disparaît” de la fenêtre Layers car il est remplacé par le frame.
Sur la gauche du frame, apparaîssent 3 bâtons droits de tailles inégales.

Quand cela ne marche pas. Un frame est,certes, créé mais il englobe le rectangle et le texte. 3 bâtons apparaîssent dans la fenêtre des layers toujours à gauche du frame mais cette fois ils sont couché un peu comme un hamburger.

Comment faut-il faire pour bien sélectionner et créer automatiquement des auto layers ?
J’ai l’impression que si on ne le fait pas rapidement… Ce n’est plus possible.
Est-ce que je n’ai pas compris quelque chose? ou c’est un bug dans le système. Cela fait un moment que j’essaie de comprendre… J’ai longtemps pensé que c’était un ordre dans la sélection mais cela ne semble pas être cela. De plus une fois que le frame est créé avec le rectangle en dessous… Impossible de trouver une solution…
Si je fais un rectangle verticale avec 4 ronds dedans et que je sélectionne tout, j’ai aussi le problème…

Je serais ravie d’avoir votre aide. J’ai essayé de télécharger des images à ce message. J’espère que j’ai réussi.

Cordialement,
C.
image

Bonjour Céline,
Merci d’avoir rejoint la communauté Figma ! De ce que je comprends de votre explication avec votre screenshot, tout m’a lair normal et prévu.

Tout d’abord, en ce qui concerne les icônes qui apparaissent sur votre panel gauche, cela est prévu.
“Sur la gauche du frame, apparaissent 3 bâtons droits de tailles inégales.” => si vous avez appliqué l’auto layout sur le frame, l’icône change par ses 3 bâtons droits qui indiquent le type d’auto layout que vous avez sélectionné.

“Quand cela ne marche pas. Un frame est,certes, créé mais il englobe le rectangle et le texte. 3 bâtons apparaîssent dans la fenêtre des layers toujours à gauche du frame mais cette fois ils sont couché un peu comme un hamburger.” Pouvez-vous confirmer que cela concerne bien ce que vous avez surligné en jaune sur votre screenshot? Si oui, votre auto layout semble parfaitement bien fonctionné. Vous voyez bien le frame 15 (avec les 3 bâtons) qui indiquent que vous avez bien sélectionné l’auto layout, et dans cet auto layout, il est inclus un elipse et votre texte en position absolue (plus d’informations sur cette propriété, (article en anglais seulement): par ici

Je vous recommande de lire cet article de notre centre d’aide qui vous explique en détail comment l’auto layout fonctionne: Explore auto layout properties et cette video: https://www.youtube.com/watch?v=floQKLsWAy4&t=2s (seulement version anglaise). J’espère que cela vous aidera !