Figma Support Forum

External GPU support for MacOS native app

  1. Figma doesn’t seem to utilise my GPU. For really large files this is a problem. When using figma on my external 4K monitor the workload stays on the internal graphics card on the Mac.

I’m running a razor external GPU with Radeon card alongside my MacBook Pro 2019 I7 … I’ve tried everything and it runs dog slow. I’ve even tried running Windows on my Mac to get the graphics card working

Recommendation from Figma support was to ‘reduce the file size’ which is really not helpful.

Does anyone else experience this?

1 Like

I have an external GPU on my MacBook. You should quit Figma, right-click on the application icon, choose “Show package contents”, then browse to Contents → Frameworks. Make sure that all the apps in there, Figma Helper, Figma Helper (GPU), Figma Helper (Plugin) & Figma Helper (Renderer) have the option “Prefer External GPU” checked in their info pane. You will need to have the eGPU plugged in if you are using macOS 10.14+ AFAIK. Re-launch Figma and perhaps take a look at the GPU history using Activity Monitor to see if that helps. It did for me.

Cheers,
Massimo

1 Like

@Massimo_Fiorentino YOU HAVE CHANGED MY LIFE!

Thank you so much. This worked a treat, wow I have been struggling for so long.

@Figma can you put this in documentation somewhere!?

Thank you again!!

No problem! I have a much smoother experience myself now :grinning_face_with_smiling_eyes: Pro tip: You can use the same trick on similar apps such as Evernote or Grammarly. They use the same foundation called Electron, a kind of HTML wrapper.

Cheers!

Thanks @Massimo_Fiorentino I was about to throw the computer out of the window!

2 Likes

Right!?!

Game changing.

2 Likes

Yes.
I remember the GPU was detected automatically in previous Figma versions, wondered why it had stopped working.

1 Like

No sweat. I was there myself! :joy:

1 Like