Figma Support Forum

Empty component instance from library in only one file

I placed a component instance from a library into a file I am working on and the component is empty. When I tested the same component in other files, it appears the way it is expected to. Additionally, when I click to go to the component’s master instance, it links accordingly.

Has anyone else experienced this @Figma_Support @Figma – is this a bug?

Can you share what the component should look like? Does this happen to all components in that library or just this specific one?

@Josh @Figma @support I am also having this issue. This issue was triggered after I updated a component in the library—all of the updated components are now empty. I tried to update a second component, and have had the same issue. This “Accordion Header” was initially hidden with a “_” prefix, and I have tried removing that prefix to see if it updates in the file where it is used—it didn’t work.

The components are showing as completely empty—I cannot click into them to see their layers:

In the component library, it renders fine: