Figma Support Forum

Does anyone know how to solve the "publishing failed" error?

I’m getting this error while trying to publish updates to a shared library:

Captura de Pantalla 2021-02-01 a la(s) 1.25.47 p.m.

Never had this error before, I thought it was a connection issue but apparently, it’s not. Maybe some corrupted component is causing it?

I’m getting the same error. Watching this question to see if a solution comes through.

From the few information that I could have on this recurring problem, we retain that the error is generally related to a corrupted component (it may contain a ghost layer, a union that contains nothing, …). The solution for some has been to remove components-to-sync from library one by one and try to publish each time to determine the infection. It’s a process that can be really painful if there are a lot of components.

So a simple way would be to contact customer support ⇢

1 Like

I tried publishing today and it worked. I have no idea what changed. I was trying to do the troubleshooting according to the instructions support gave me, and then it just published without problems.

1 Like

This is one of those issues that seems to be coming up a lot, but there is no solid solution (that I have found). In my case it’s def holding up progress across our entire organization.

Here’s my current “publishing failed” details:

  • File will not publish
  • This has happened before and the next morning everything was working fine
  • Though there are some performance issues with our library file, the publishing issue is the only one that one we cannot easily work around (l’ll be honest here - if you’ve been a system designer for a while, you know it’s often a matter of ‘managing’ performance rather than ‘dealing with issues’, but this bug seems in a league of it’s own).
  • I def tried publishing on different machines
  • I contacted Figma directly when this happened the first time (and again today) and their previous response was to point me to the ‘best practices,’ and mentioned that not following them could lead to performance issues. I’ll be honest, when this many people have that issue, there should be something more (that perhaps I couldn’t find) that directly connects the issue with the solution (even if it is working around a bug). Having said that, I let it go as ‘it fixed itself’ the first time the issue came up.
    *I’ll update when the next figma response comes in (usually 24 hrs)
    *some of the message boards suggest this error can be due to a ‘corrupted component’
    *I definitely love all that Figma does, but this is the first time that Figma has been a major blocker (velocity / reliability / OKR) in my years using it.

Getting this problem today. Just added a component to a library I’ve been using with no problems. What a helpless feeling. I guess this library is toast now? Is there any kind of error log I can be looking at?

This library is tiny, by the way, but I use it in dozens of files.

Just getting it myself today for the first time. Since I’ve only made a few changes to the library in the past day, there weren’t that many boxes to un-tick to try to figure out which component is causing the problem… except that didn’t change anything. Maybe it’s every component I’m trying to publish? Yes, this is a major velocity blocker!

AND… two hours later I was just able to publish. Without having changed anything. Think it might have been a bug they fixed? (btw, this is all in the app. Next time I’ll try browser too).

Also got this using the Mac App. I switched to the browser (chrome) and tried it there and it was able to publish it there.

You need to close open tabs linked to other accounts. Something causing conflict happens, if projects from different accounts are open on your tabs.