Desktop App Figma v114.4 - High CPU usage when editing


I’m on the latest Figma v114.4 on Windows 10 using the desktop app. When i start editing something in my file the CPU load goes up and doesn’t recover. CPU usage is fine when i just load a file and move/zoom around. It starts when i edit something.

I suspect it has something to do with the latest update which i installed today. Can you confirm there is a performance issue?

How can i roll the version back to see if there is an issue with the latest version?

Thanks for your help

It doesn’t seem to happen with a newly created file and just a single component in it.

My actual file is rather large. I’ve just tried to reduce/cleanup a copy of that specific file but the performance issue persists.

All that leads me to the assumption that my actual file is possibly corrupted/compromised.

What can i do now?

I tried to reduce my file further. I copied just a single frame into a newly created file:

CPU (idle, test file is loaded) is 0-1% (1-2GHz)

Now i show/hide some element in that frame:

CPU (after editing something) 15-20% (4-5GHz)

The issue is that the CPU doesn’t come back down to idle state.

Problem is gone. I can’t reproduce the issue anymore. Maybe the problem was related to auto-save not working yesterday?