Figma Support Forum

"Copy as SVG" now works worse

Here is a trivial icon:

Couple of months ago when I copied it as SVG, the output code was:

<svg viewBox="0 0 16 16" width="16" height="16" xmlns="http://www.w3.org/2000/svg"><path d="M9 6H7V4h2zm0 1H7v5h2zM8 1.6A6.4 6.4 0 1014.4 8 6.408 6.408 0 008 1.6zM8 0a8 8 0 11-8 8 8 8 0 018-8z"></path></svg>

But nowadays the output code is much longer:

<svg width="16" height="16" viewBox="0 0 16 16" fill="none" xmlns="http://www.w3.org/2000/svg">
<path d="M9 6H7V4H9V6ZM9 7H7V12H9V7ZM8 1.6C6.7342 1.6 5.49683 1.97535 4.44435 2.67859C3.39188 3.38184 2.57157 4.38138 2.08717 5.55083C1.60277 6.72027 1.47603 8.0071 1.72297 9.24858C1.96992 10.4901 2.57946 11.6304 3.47452 12.5255C4.36957 13.4205 5.50994 14.0301 6.75142 14.277C7.9929 14.524 9.27973 14.3972 10.4492 13.9128C11.6186 13.4284 12.6182 12.6081 13.3214 11.5556C14.0246 10.5032 14.4 9.2658 14.4 8C14.3979 6.30326 13.7229 4.67663 12.5231 3.47685C11.3234 2.27708 9.69674 1.60212 8 1.6ZM8 0C9.58225 0 11.129 0.469192 12.4446 1.34824C13.7602 2.22729 14.7855 3.47672 15.391 4.93853C15.9965 6.40034 16.155 8.00887 15.8463 9.56072C15.5376 11.1126 14.7757 12.538 13.6569 13.6569C12.538 14.7757 11.1126 15.5376 9.56072 15.8463C8.00887 16.155 6.40034 15.9965 4.93853 15.391C3.47672 14.7855 2.22729 13.7602 1.34824 12.4446C0.469192 11.129 0 9.58225 0 8C0 5.87827 0.842855 3.84344 2.34315 2.34315C3.84344 0.842855 5.87827 0 8 0V0Z" fill="black"/>
</svg>

I’m wondering why? :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.