Copied Component, Pastes as Plain Text

Does this happen to anyone else? We have an Organizational-level Figma plan. I want to copy a component from another file and paste it into our file. I copy the component using Command-C on a Mac and paste it using Command-V.

Instead of getting the component, I get a block of text. Here’s a screen capture.

Do you know if there is a setting I need to turn on?
Signed Frustrated on the Figma Frontier

Hi @Morris_Joe that does look strange. I’ve tested copying a variant from one file and pasting it to another using the keyboard shortcuts but did not experience this issue.

Maybe try clearing your browser or desktop application cache and see if that helps or try reproducing across different browsers. If you are seeing this in a browser, you may have an extension enabled which might be blocking this function.

If you are still experiencing this issue, please reach out to the support team directly via this form for help: https://help.figma.com/hc/en-us/requests/new

Be sure to use your Figma account email, include links to the file, and share it with support-share@figma.com so they can take a closer look.

It turns out it is my local environment. I have two apps that might have triggered this glitch: “Copied” or “TextExpander.” When I disabled both of them I could copy and paste components between files and within the file. Problem solved.

Thanks Figma team for having a look and verifying everything works as expected.

:trophy:

This topic was automatically closed after 30 days. New replies are no longer allowed.