Figma Support Forum

Content clipping with scroll overflow

I have graphical elements extending outside my frame which is to be clipped. And I have content to the bottom of my frame for vertical scroll. Turning clipping on or off doesn’t seem to have much effect on the content outside the frame in “present” mode.

Peek 2021-09-17 14-39

How does one go about doing this?

Set the height of your main frame to the height of all your content.

Thanks for the suggestion. Just tried that with and without clipping checked. But content outside the frame is still being displayed in “present” mode.

Another interesting observation is that it works (clipped content is hidden) when in “Fit - Scale down to fit”, but then there is no scrolling. Clipped content is still visible in “Width - Scale down to fit width” and “100% display at full size”.

Sorry, I don’t quite understand what you want to get. Do you want your content to not scroll vertically? Have you tried specifying “Custom size” in the “Device” section on the prototype tab?

Tried setting Device dimensions as you suggested, but that doesn’t seem to do anything. I just want clipped content to stay hidden during presentation. Even when scrolling.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.