Change default artboard resize behavior - I do not ever want elements moving with it

It’s not intuitive to hold down Command, and I keep forgetting, or I accidentally let go to soon and don’t realize it. Like every single day I get 20 steps into something and realize a bunch of tiny elements are in the wrong place on my artboard and it’s too late to undo everything, so I have to manually go through and fix this. The weirdest part is that none of the other elements move, but a bunch of SVG icons I have in there always end up movnig.

I’m sorry but this behavior simply is NOT INTUITIVE. If you want to give the ability to resize things with the artboard, use a checkbox, or make that the “command+” behavior. The default should not be like this.

Does anyone know if there is a setting for this somewhere?

There isn’t a setting for this, but it is how most software of this kind behaves. SVG icons are usually placed as frames, and by default any frame placed inside another frame will get default constraints rules applied to them, this is probably why they move around and others don’t.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.