Can't open the Figma Mac desktop app due to a javascript error

I have the same error this morning, did anyone find a solution?

Same issue here. The whole company cannot open the Figma app and is obliged to use the very slow browser version.

Maybe Maybe And Maybe its a connectivity issue, Try using dns or VPN to see if that help but again it’s just a Maybe

Same error here

Same problem, also M1 mac, and no, there are no connectivity issues and nothing was changed from the users side, except of trying to close figma as usual.

Looks like deleting and reinstalling the desktop app may fix the issue

I tried uninstalling and re-installing. No resolve.

Same here - identical error on iMac

Same here on MacBook Pro (16-inch, 2019) on MacOS Monterey 12.6.1. Does not work on VPN and off VPN. Bypassing for the time being with the Figma Beta App (which works)

Same error on my 2020 M1 MacBook Air, I can delete and re-download which fixes it but encounter the error again every time I restart or login to a different account on my computer.

I think it’s best to relocate this topic into bug and requires some attention.

It’s not an individual problem anymore.

@Figma_Support @Josh Please help to get this noticed.

1 Like

Hey all, we have this logged internally and are taking a look at what might be happening here. I just reached out to the team and will report back when I have some more info. Thanks!


Hello, same issue happened to me.

It seems to be happening when I try to import an image from my files in the side panel.

I need to unistall & re-install.

Might be worth noting I’m using Figma on a MBP M1 with 2 sessions, both containing Figma. Issue is happening on both.

Hey all, we just pushed a fix for this. Can you try re-downloading the desktop app to see if the problem persists?


1 Like

Yes! The app works again - thank you wonderful people for fixing this so fast!

1 Like

Glad it’s working again for you. Thanks for confirming! :blush:

Anytime Josh! I’ll happily help test Betas as well if you have Beta programs!

Here’s a list of our current betas

The Desktop one is open to everyone!

1 Like

Same issue after updating to MacOS Monterey.

I reinstalled Figma. Works now. Thanks.

1 Like