Figma Support Forum

Can't access full-size images in table view: "you don't have permission to view this prototype."

We’ve been having this specific issue lately.
At first, we encountered this error when we tried to share a figma file to a coworker. He said, at first day, accessing the full-size original image in figma was okay, but the following day, it didn’t work anymore. And it gave him this error when he clicks the link and it opens a tab in the browser:
“you don’t have permission to view this prototype.”

I am the owner of the file (so I assume I have 100% permission for that). Today I tried doing the same steps, and it also gave me THE SAME ERROR.

I thought it might be a bug. it’s a cropped image inside figma, so I switched it to ‘full’. I also removed the blur effect, removed all overlays etc. And tried the same steps, but still same error.

Here’re the steps that I did in trying to view original image:

  1. Select the proper image layer from the layers panel
  2. Open ‘inspect’ tab from the right panel
  3. switched to ‘table’ view from the default ‘code’ view.
  4. clicked on the link pointed in the ‘file name’ field.
  5. Ideally it will open the image in the default browser as a new tab in full scale.

I believe this is a bug. It also happened to other figma files as well, not only to one specific document. Please help.