Blurry images

I am seeing many of my images (screenshots and stock images) becoming pixelated/blurry. I bring them in and they look fine, and sometimes, randomly, they will all of a sudden become blurry. They also export this way. In some files the same image looks ok, and when I copy/paste into another they look blurry. Additionally, sometimes the images look fine for me, and not for others. I do not think this is a loading issue because they do not resolve after time.

I saw another post about the same issue and they had no response (paul_middelkoop on Aug 19), can you please help advise?

6 Likes

Yes, want to piggy back on and say I’m getting this in Figjam as well. Paste in a jpg and it’s pixelated. Can’t read medium sized text on a screen capture of a sample webpage, for reference, for instance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Why is there no Figma support reply on this issue??

"I am seeing many of my images (screenshots and stock images) becoming pixelated/blurry. I bring them in and they look fine, and sometimes, randomly, they will all of a sudden become blurry. They also export this way. In some files the same image looks ok, and when I copy/paste into another they look blurry. Additionally, sometimes the images look fine for me, and not for others. I do not think this is a loading issue because they do not resolve after time.

I saw another post about the same issue and they had no response (paul_middelkoop on Aug 19), can you please help advise?" Posted by @lauren_okura(Figma Support Forum - Figma Support Forum)

1 Like

I was having the same issue and got it resolved by making the canvas smaller. In my Figjam there were other elements scattered all over the place making the canvas too wide and long. When I trimmed or removed out the extra elements all the images went back to normal.

I’m having a similar issue - copying and pasting within two different files shared w/ the same user. Is there a solve for this?

restarting my computer, reopening and reducing the file size helped!