Figma Support Forum

Asset search showing stray components

Hello! I have a design system in a published document. Within the Asset search I keep seeing stray component instances even though I assured they no longer exist in the document. The document is not sharing any other libraries. How could I remove these stray instances from my Asset search?

I’m having this same issue. I’d been working with several versions of libraries to test them out, and I think I have everything correctly wired up for my latest (different file) libraries. However, it’s still telling me I have several styles and components from the outdated and unpublished libraries in use. It shows me the component “in use” in the dialog, but I can’t focus it to know where the instance is hiding. I also have tried using the Find/Focus plug-in to find a component by name in my layers for every single page and nothing comes up. (Incidentally, ability to search Layers natively is a glaring absence compared to Sketch; have to use a plug-in to make up for it)

Yes I’ve tried both Find/Replace and Instance Finder plugins and both did not find residual instance traces, yet they still show up in the Assert search. Frustrating.

The bigger issue when you have extinct components in the Assets search results. You cant drag them in. The process of restoring them is long. Figma should allow right-mouse (RM) click replace with… or RM locate on canvas (many times these are old components from dead libraries so they show as “used in this file”) Ideally Figma should give options to only display results from my switched on libraries, and hide what’s on the canvas or Local components. or at least list them in sections so we know what to ignore.

If you need more help contact me www.ConciseUX.co.uk

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.