After assigning variables to my button component, the size property malfunctions

Technically the size property still works. However the buttons resize to much lesser sizes than defined in the component set. The border radius property doesn’t work as well. Has anyone had a similar issue?

Hi @Dovydas_Feigelovicius do you have an example or a short video showing the issues you are seeing?

hey @Ryan_52. I tried uploading the video unto here but it says new users aren’t allowed to. Here’s the youtube link Screen Recording 2023 07 24 at 09 39 47 - YouTube, lemme know if that’s enough context.

here you can see what happens when I remove the variables Screen Recording 2023 07 24 at 09 56 46 - YouTube. The component goes back to normal behaviour


variable inflicted odd button behaviour

HI @Dovydas_Feigelovicius thank you for those videos. I’ve tried to recreate the issue from my end here but was unable to when having a variable binded to horizontal and vertical padding.

Can you please reach out to the support team directly via this form for further help: https://help.figma.com/hc/en-us/requests/new

Be sure to share a video of the issue, include the links to the file, and share it with support-share@figma.com so they can take a closer look.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.