Figma Support Forum

AEUX plugin error

Hi there, my AUEX plugin stopped working out of nowhere
"Manifest error: Missing editorType in manifest. Specify one or both of ["figma,“figjam”]


Tried reinstalling everything but nothing… also cant find anything about it on the internet… any ideas?

Specify the editor type in the manifest.json file.

Thanks Tank, I`m leaving the full manifest code here for future consultation

{
  "name": "AEUX",
  "id": "864522107465619637",
  "api": "1.0.0",
  "main": "dist/code.js",
  "ui": "dist/ui.html",
  "editorType": [
    "figjam",
    "figma"
   ]
}

2 Likes

Thank you! This fixed it for me!

1 Like

Thanks image

1 Like

My manifest file reads exactly like this so I’m not sure why I am getting an error message here

figured out my goof. You have to open the readme.md file( just dropped it into a browser window) here is the excerpt below:

This plugin template uses Typescript and NPM, two standard tools in creating JavaScript applications.

First, download Node.js which comes with NPM. This will allow you to install TypeScript and other
libraries. You can find the download link here:

link redacted- nodejs dot org

Next, install TypeScript using the command:

npm install -g typescript

Finally, in the directory of your plugin, get the latest type definitions for the plugin API by running:

npm install --save-dev @figma/plugin-typings