Figma Support Forum

2 Editors not working on free plan


I am trying for days now to set another editor for my figma file (I’m on the free plan).

Whenever I do it I get:

“Upgrade to Professional
You’ve reached your plan’s 2 editor limit. The user you’ve invited will be granted view access, but they won’t be able to edit.
You may give them edit access later if you upgrade to the Professional plan or downgrade other editors on your team to viewers.”

My settings before I try to add the user looks like that. So just one owner and no other editor!

Can someone help me?

Thanks a lot :slight_smile:

Make sure none of the individual files has a share setting different than your global.

Thanks for the quick reply. Can you help me what you mean with individual files and global? I thought the permission is always file specific.

Permissions can be file and team-specific. If you have a second editor in another file, you won’t be able to add a different editor to a different file in the same team.
Go to team settings and you will see all editors in the team.

I’m having the same issue. At the team level, there is one owner (me) and one editor. I try to add another team member as an editor and am being prompted to upgrade.

For the file within the project, there are a bunch of viewers, but again only myself as owner and one other editor.

My other teammates don’t have this problem with other files. Help!

I have the same problem, I solved it by taking my project to the “draft” section, give the editing permissions there and then return it to my team

1 Like